Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 21, 2017 - 12:20 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 7 months ago. Jan 21, 2017 - 12:16 PST