Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 06, 2018 - 13:11 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 9 months ago. Feb 06, 2018 - 13:10 PST