Email delivery issues to hotmail.com
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 04, 2018 - 12:15 PDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. May 28, 2018 - 09:45 PDT
Investigating
Due to circumstances beyond our control, we are experiencing deliverability issues of emails to hotmail.com email accounts. This affects all emails from Medium, including sign-in and sign-up emails. We are continuing to address this issue, and apologize for the inconvenience.
Posted 5 months ago. May 25, 2018 - 17:10 PDT