Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 8 months ago. Jul 27, 2016 - 01:07 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 8 months ago. Jul 27, 2016 - 01:07 PDT