Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 11 months ago. Jul 27, 2016 - 01:06 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 11 months ago. Jul 27, 2016 - 01:06 PDT
This incident affected: Medium Front End.