Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 12 days ago. Jul 07, 2018 - 05:07 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 12 days ago. Jul 07, 2018 - 05:06 PDT