Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 31, 2016 - 13:25 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 8 months ago. Oct 31, 2016 - 13:12 PDT
This incident affected: Medium Front End.