Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 08, 2016 - 10:18 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted about 1 year ago. Dec 08, 2016 - 10:16 PST