Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 10 months ago. Aug 02, 2016 - 01:41 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 10 months ago. Aug 02, 2016 - 01:40 PDT