Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 06, 2016 - 08:21 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 7 months ago. Sep 06, 2016 - 08:21 PDT