Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 26, 2017 - 07:29 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted about 2 months ago. Jan 26, 2017 - 07:28 PDT