Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 27, 2016 - 00:34 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted about 1 year ago. Jul 27, 2016 - 00:34 PDT