Delayed Stats and Notifications
Incident Report for Medium
Resolved
The processes have caught up, and delivery of stats and notifications are back to normal
Posted 11 months ago. Jun 06, 2018 - 14:25 PDT
Investigating
Some stats and notifications are experiencing delays. We are beginning to recover now, and apologize for the inconvenience.
Posted 11 months ago. Jun 06, 2018 - 13:28 PDT