Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 20 days ago. Sep 28, 2017 - 16:57 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 20 days ago. Sep 28, 2017 - 16:39 PDT