Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 06, 2017 - 02:24 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 5 months ago. Feb 06, 2017 - 02:24 PST