Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 11, 2017 - 16:13 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted about 1 month ago. Jul 11, 2017 - 16:12 PDT