Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 19 days ago. Aug 02, 2017 - 16:53 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 19 days ago. Aug 02, 2017 - 16:51 PDT