Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 21 days ago. Nov 21, 2017 - 10:34 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 21 days ago. Nov 21, 2017 - 10:33 PST