Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 11, 2017 - 16:18 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 4 months ago. Jul 11, 2017 - 16:14 PDT