Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 29, 2017 - 12:36 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 2 months ago. Sep 29, 2017 - 12:34 PDT