Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 19 days ago. Sep 29, 2017 - 12:18 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 19 days ago. Sep 29, 2017 - 12:17 PDT