400 Errors
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 06, 2017 - 07:07 PST
Investigating
We are investigating reports of 400 errors for some users. Please bear with us.
Posted about 1 month ago. Nov 05, 2017 - 23:22 PST