Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 7 months ago. May 02, 2017 - 08:31 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 7 months ago. May 02, 2017 - 08:07 PDT