Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted almost 2 years ago. Aug 09, 2016 - 09:05 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted almost 2 years ago. Aug 09, 2016 - 09:04 PDT
This incident affected: Medium Front End.