Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 23 days ago. Oct 30, 2017 - 18:59 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 23 days ago. Oct 30, 2017 - 18:38 PDT