Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 24, 2018 - 17:08 PST
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted about 1 month ago. Jan 24, 2018 - 17:07 PST