Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 01, 2017 - 15:04 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 3 months ago. Apr 01, 2017 - 14:32 PDT