Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 27, 2017 - 07:00 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 5 months ago. Jul 27, 2017 - 06:58 PDT