Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 2 months ago. May 02, 2017 - 07:58 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted about 2 months ago. May 02, 2017 - 07:57 PDT