Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 02, 2017 - 16:31 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted 4 months ago. Aug 02, 2017 - 16:29 PDT