Delayed stats
Incident Report for Medium
Resolved
This incident has been resolved.
Posted 9 months ago. Nov 10, 2016 - 23:00 PST
Monitoring
Due to unusually high traffic, our stats pipelines are backed up. Post stats and recommend counts may be delayed.
Posted 9 months ago. Nov 10, 2016 - 12:26 PST