Service Interuption
Incident Report for Medium
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 13, 2017 - 10:54 PDT
Investigating
Some users are experiencing problems accessing Medium, our team is aware and investigating.
Posted about 1 month ago. Mar 13, 2017 - 10:53 PDT